Page 1 of 2

I'm new

Posted: Fri Nov 01, 2019 12:57 am
by lucashuy
I'm trying to compile an simple thingy for the MSX, BUT it always does this error...

Z:\Utils\Vasm\vasmmsx.bat yuh.asm C:\Users\Lucas\Downloads\Z80EXPORTS nopause
Process started >>>
The system cannot find the path specified.
<<< Process finished. (Exit code 3)
================ READY ================

Help me please.

Re: I'm new

Posted: Sat Nov 02, 2019 12:33 am
by akuyou
I'm assuming you've mapped the Z drive OK
Copy the ASM file onto the Z drive, and try again...

One thing to note:
I'm not sure what YUH.asm is... I don't think it's anything I've written - so I'm not sure what will happen when it's compiled, as the compile scripts are designed to work with the origins and other definitions of my ASM files

Re: I'm new

Posted: Sun Nov 03, 2019 12:22 am
by lucashuy
It still doesn't work.
It says the same thing.

Z:\Utils\Vasm\vasmmsx.bat yuh.asm Z:\zex nopause
Process started >>>
O sistema não pode encontrar o caminho especificado.
<<< Process finished. (Exit code 3)
================ READY ================

Here is the code:
BuildMSX equ 1

PrintChar equ &00A2

include "..\SrcALL\VasmBuildCompat.asm"

;For Cartridge
org &4000
db "AB"
dw ProgramStart
db 00,00,00,00,00,00

call &006F

ld a,32
ld (&F3B0),A

ld hl,Message
call PrintString


push af
ld a,6
call PrintChar
ld a,10
call PrintChar
pop af

ld a,(hl)
cp 255
ret z
inc hl
call PrintChar
jr PrintString

Message: db 'yeetus',255

org &C000

Re: I'm new

Posted: Sun Nov 03, 2019 4:22 am
by akuyou
Firstly, please accept my apologies, you need a special build script for this file that currently isn't in the tutorial package - the reason for this is the 'super simple' series creates the MSX cartridge header in the code, rather than letting my script do it - the intention was to make it easier for people not using Vasm or my scripts to port to other systems.

I've attached the correct script to this post... please put it in z:\Utils\Vasm\
(464 Bytes) Downloaded 53 times
You can then use this compile script to do the build:

Code: Select all

z:\Utils\Vasm\vasmMSX_DirectCart.bat $(FILE_NAME) $(CURRENT_DIRECTORY) nopause
I need to update the devtools package, but the version I'm currently using for new tutorials and programming needs a lot of 'clean up' work, and I don't have any spare time right now... I'm hoping I may be able to do a new release in the new year.

That said, the error you're getting is *not* related to this script... it's trying to run the normal MSX script included in my tutorials and can't find it,
Do you have a newer copy of Notepad++ on your machine perchance? I know newer versions do not work well, as they always run from the path of notepad, not the drive letter the current file is on

If all else fails, you can always run your script from a normal command line - I just tried it, it works!
MSXprob.png (21.41 KiB) Viewed 1407 times

Re: I'm new

Posted: Sun Nov 03, 2019 12:32 pm
by lucashuy
It still didn't work!
I'm running Windows 10 64-bit. All i wanted is to do some simple games! But NotePad++ for VASM is being annoying.

Re: I'm new

Posted: Sun Nov 03, 2019 12:44 pm
by akuyou
Even the command line one didn't work? That surprises me, as I downloaded a fresh copy of my own tutorials, copied your file to the location, and added the batch file I gave you before taking the screenshot.

Please try the command line method I show above, and let me know what error message you get? can you provide a screenshot.

I've used these tools on Windows 10 64 bit myself - and Notepad++ is not the problem if even running from the command line did not work.

Re: I'm new

Posted: Sun Nov 03, 2019 1:07 pm
by lucashuy
The command line thingy doesn't work either. It just entirely disappears.

Re: I'm new

Posted: Sun Nov 03, 2019 8:14 pm
by akuyou
OK, my best guess is that you ran the link to Notepad++ first not from the Z drive and windows has now broken that link (making it point to C)... Thinking about it, I've seen that happen to people before.

Try copying the Notpad link back from the original DevTools.7z onto the Z drive and running it again

But that would not explain why the command line version did not work... I really don't know what else to suggest at this point.

Re: I'm new

Posted: Wed Nov 06, 2019 5:16 pm
by lucashuy
I actually didn't extract it all from a Devtools.7z because i didn't get the file in the first place. The file i used is LearnZ80Dev.7z.

Re: I'm new

Posted: Wed Nov 06, 2019 8:23 pm
by akuyou
I mis-spoke when I said DevTools.7z - the file you extracted was correct, but when I did it, it worked, I can only assume something is going wrong on your machine...

I can't help you any more at this time, I can't work out what is wrong, there's too many possible factors.

I will create a new set of 'Z80 Dev tools' over the Xmas vacation which will be more reliable (I now use a portable version of Notepad++, and my batch files check if everything is in the correct place and give proper warnings), but I can't do it before then due to time constraints... Can you wait until the new year and we'll revisit this then?